Caynax quits chiming after 3-4 days

Samsung S6 on Android 7.0. Pro user. The main Hourly Chime screen shows next weekday chime for tomorrow at 6am. My settings are to chime from 6am to 10pm daily. Caynax worked properly yesterday. Have made no phone or Caynax settings changes. This happened a few days after initially installing CHC. I uninstalled, reinstalled and all was well again. Any solution other than uninstall, reinstall?

Please go to device battery settings and turn off “Battery/Application optimization” for this app.

Please turn off Doze mode for this app:

Thanks for your input but that cannot be the issue. Those settings are not turned on. And a reminder, the app worked correctly yesterday and for several days previous.

I uninstalled, reinstalled, imported my settings and the app still will not chime on any hour.

… and the app shows next chime time to be 6 a.m. tomorrow. It’s ignoring every time set for today.

Success by deleting the ‘Weekday’ chime and re-creating it. Now the app chimes on the hour and the upcoming hour appears as the next chime on the main screen. Wonder what could make a chime group get corrupted?

I don’t thank this could be the issue.
There is delay problem in all Android 5+ and especially 6_ and 7+ devices. This is due to device battery optimization (and sometimes possibly by improper devices manufacturers modifications). This app forces Android device to always start at exact time - no matter in what state device is (chimes are set as alarm clock).

Inside app “Advanced” settings there are two additional options you can try.

I have similar problem, though for me deleting “Weekday” chime didn’t help.
App worked perfectly, when I installed free version. I needed more minutes option, so I bought pro subscription and some time after that it stopped chiming.
Battery optimization is off, app is on protected list.
I tried advanced options in app settings.
I uninstalled and reinstalled app.
There were no system updates.
I can add chimes and groups, change settings, yet nothing works, not even when screen is on. No chimes, no vibrations.

Are you also Samsung user?

I have same problem on Honor View 10. It was working great on Android/EMUI 8.1 but I have issues since update to Android 9.0 or 9.1.
When I run app manually, it works for a day maybe two (hard to tell, I use only a couple of chimes a day) but then it stops until I run it again. I have disabled all battery optimisations for Hourly Chime Pro I could find, enabled all those Auto-launch, Secondary launch, Run in background options, and I have “Set chime as alarm clock” checked… And yet, it still doesn’t chime after day or two.

Hi. Please check that screen if you got all optimizations turned off:

Copy image location and open in new window.