GPS signal lost

I have a Samsung 10e, Android 11. After the Android update Aug 30, the GPS is lost very often when the screen turns off. The signal connects when the screen turns on. This has never happened before after several months of usage. I have changed the battery settings as instructed. What can i do to fix it?


Same problem here, only working with screen turned on. Samsung 10e and 2 with same problem after udateret

1 Like

I have the same problem. The app cannot be used with this problem. I have Samsung Galaxy S20 FE

Removed the old App and installed from scratch, both my phones are now working fine again.

Uninstallation and new installation of the app does not improve or repair anything with gps or battery saving to me.

S10, same problem, may be since September update.

I had komoot app running in parallel, Gps in komoot worked properly without any problems

In my S20 FE 5G the same - Mi Fit working correct, Caynax lost GPS - since last update…

1 Like

Same problem with GPS data: app stops logging GPS data when the screen is off.
Using Pixel 3a android 11 with September security update.

Same for me on Pixel 4 Android 11 Sept 5 update, whenever the screen is off. I noticed that “Allow Always” location permission is not available?

1 Like

This is how it looks.
We are trying to keep used permissions to required minimum so our app has access to Location/GPS while it is being used in the foreground = we display constantly visible “Application running” notification. So it kind of looks/works like music player app: running actively but also running in the background when you turn off device screen.
We use permission “Allow (GPS) only while app is being used”.

Most of other apps want you to allow them to “Allow (GPS) location all the time”. And these apps work after recent Samsung and Pixel updates correctly. Our stopped working because they broke that functionality.
Unfortunately at almost the same time we released our app new update so some users might think that this is us who broke something.
It looks like we/you have to wait for system update. Some users report that September update fixes the issue. Unfortunately others that it don’t.

App music works fine but Caynax dont.

But music app does not need your GPS permission :). Our app when it comes to “music app” comparison also still works (fine) in the background but no longer receives GPS data.

Update: one of our devices got update that (finally) broke that functionality so we can test whether we can do anything about.

Hello all,

I ran this morning and no luck. Everything remains the same. I attach images of my configuration.

It is sad that until there is an update we cannot use the application. Caynax can you do some kind of pressure to google / samsung, :smirk:?

Best regards

We prepare update that “fixes” it but it will require from user to grant application permission to allow to use GPS all the time and we are concerned that other users who don’t experience that problem will give us bad ratings.

Please do it faster and don’t worry about bad grades. There won’t be any!

Yesterday we found out that Samsung also reports NaN (Not a Number) for getSpeed() so it looks like more is broken :/.

Solved with the last patch. Thanks a lot

Thanks, Caynax Tracker works again.
It works since October Samsung SW update.
However I do not understand why e.g. Strava is fine with permision “Allow (GPS) only while app is being used” but Caynax Tracker needs “Allow (GPS) all the time” to work like strava with no problem.
This is strange for me.

It might be “brand case”. Some well known apps like Twitter, Facebook and previously Endomondo are not battery optimized.