No alarm sound in DND

I set Cynax Pro to override do not disturb but it doesn’t, and sometimes DND gets stuck on and I miss my alarm. Moto G stylus 5G 2022. Android 12.

Please also mark “Chime in silent/vibrate mode”

Those are both checked on all alarms. Is there another place to check it too?

Beside that and allowing app to modify DnD mode settings that should be all.

Cynax Pro only vibrates on DND, which is not adequate to wake me up. I even uninstalled, reinstalled, and checked and updated all settings. It even does the same when you try “check alarm”.

I have switched to the stock clock for my wake up alarm for now, which works fine with DND.

I like Cynax because you can set snooze details, like I set alarms for 3 minutes before meetings, with multiple 1 minute snoozes. I can’t do that in stock clock. It would be great if Cynax Pro worked for DND.

Also, this is for Cynax Alarm clock pro, not hourly chime. I guess I selected the wrong category originally? Can it be changed?

Ps. Did you allow app to modify DoNotDisturb mode beside setting that "alarm in silent/vibrate mode??

Yes, I did. My phone recently updated to Android 13. Same issue with Caynax Alarm Clock Pro only vibrating when in DND. Stock alarm clock works fine in DND.

Why can Caynax Alarm Clock Pro still vibrate in DND, but no sound? It is only half overriding DND. Stock alarm clock fully overrides DND.

Can you please go to “About app” section, enable “Enable logging” and next time it happens send me logs from the same “About app” section?

Thanks. I sent it earlier today.

Unfortunately I don’t see anything strange there. I will soon start working on app version that will so called “target Android 13 (devices)” so please check whether that version will make any difference. It will be named the same as Android version that it targets = 13.

Thanks. I will check the newer version when it comes out.