Screen Rotation Stuck in Landscape

Shift worker here who has used the app for about a week and loves it so far, except for one thing:

The app forces landscape. No amount of orientation or enabling/disabling Auto-Rotate changes this. It only operates in landscape mode. I thought this might be just in the free app, so I purchased the Pro version, but it occurs there too.

I’ve been through every menu I can find, and don’t see a setting, and it is only this app that it happens. Haven’t seen anything on the forums or web search about this either. Not a complete deal-breaker, but it is annoying.

I’m on a Google Pixel 7 Pro running Android 14.

Thanks in advance!

I’ve been using it in portrait mode since Day 1 and pro version. I’m using Samsung phone.

I’m on a Pixel 6 Pro and also stuck in landscape. Moreover, the only settings I’m able to see on the phone are chimes and phone alarm settings. All other settings for chimes, other than days of the week, are not visible on my phone. Did anyone contact you about this issue yet?

It looks app wrongly detected your device as tablet and switched to landscape UI.
Alarm clock has inside settings option “Use tablet UI”. Please uncheck it.

For Hourly Chime there is no landscape UI supported but app also didn’t force device to use portrait mode. I will change that.

Please update to 13.1.2 app version (available gradually to all users). Inside app settings → application appearance → there should be option to switch back to portrait orientation.